Author Topic: Calibre problem (sending error)  (Read 384 times)  

Offline leesnail

  • Status: Dr. Seuss
  • *
  • Posts: 1
    • View Profile
Calibre problem (sending error)
« on: December 01, 2017, 09:19:12 AM »
I'm trying to send newspaper with Calibre.
But whenever I e-mail test, I got error code like this;

Traceback (most recent call last):
  File "site-packages\calibre\gui2\wizard\send_email.py", line 207, in test_email_settings
  File "site-packages\calibre\utils\smtp.py", line 154, in sendmail
  File "site-packages\calibre\utils\smtplib.py", line 647, in login
SMTPAuthenticationError: (535, 'Authentication credentials invalid')

Log:
connect: (u'mail.gmx.com', 587)
connect: (u'mail.gmx.com', 587)
reply: '220 gmx.com (mrgmx103) Nemesis ESMTP Service ready\r\n'
reply: retcode (220); Msg: gmx.com (mrgmx103) Nemesis ESMTP Service ready
connect: gmx.com (mrgmx103) Nemesis ESMTP Service ready
send: 'ehlo [192.168.0.11]\r\n'
reply: '250-gmx.com Hello [192.168.0.11] [1.236.152.60]\r\n'
reply: '250-AUTH LOGIN PLAIN\r\n'
reply: '250-SIZE 69920427\r\n'
reply: '250 STARTTLS\r\n'
reply: retcode (250); Msg: gmx.com Hello [192.168.0.11] [1.236.152.60]
AUTH LOGIN PLAIN
SIZE 69920427
STARTTLS
send: 'STARTTLS\r\n'
reply: '220 OK\r\n'
reply: retcode (220); Msg: OK
send: 'ehlo [192.168.0.11]\r\n'
reply: '250-gmx.com Hello [192.168.0.11] [1.236.152.60]\r\n'
reply: '250-AUTH LOGIN PLAIN\r\n'
reply: '250 SIZE 69920427\r\n'
reply: retcode (250); Msg: gmx.com Hello [192.168.0.11] [1.236.152.60]
AUTH LOGIN PLAIN
SIZE 69920427
send: 'AUTH PLAIN AHM0NDUwNDYyMEBnbXguY29tAHMxMTQwMzY5NDcz\r\n'
reply: '535 Authentication credentials invalid\r\n'
reply: retcode (535); Msg: Authentication credentials invalid

Is there anyone who know about this?

Offline Jaasy

  • Status: Scheherazade
  • *****
  • Posts: 1870
  • Gender: Female
  • Texas
    • View Profile
Re: Calibre problem (sending error)
« Reply #1 on: December 01, 2017, 02:34:22 PM »
This looks like what I ran into when I set mine up.  Go into your GMX email settings and activate your POP3 & IMAP settings, SAVE. That worked for me.

Offline rhymedog

  • Status: Dr. Seuss
  • *
  • Posts: 1
    • View Profile
Re: Calibre problem (sending error)
« Reply #2 on: January 10, 2018, 06:27:50 AM »
Thank you for posting the solution to this problem, Jaasy! That worked for me!