Kindle Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
1,167 Posts
Discussion Starter · #1 ·
Hey,

Here is the email they sent me. If you know how to fix this, please let me know.
And I suck with Tec stuff so please go slow.lol.thank you:)

Text in your book is unreadable for readers using color devices and reading on a black background. This may have occurred due to forcing the font color to black in your source file. To correct this issue, please remove all forced formatting from your font.You can see examples of this error at the follow location(s): Kindle Location :3845
 

·
Premium Member
Joined
·
63,460 Posts
Do they say which book it is?  I looked at Guardians on my Fire with a black background and everything looked fine, even at the location they cite.

Betsy
 

·
Registered
Joined
·
1,167 Posts
Discussion Starter · #3 ·
Betsy,

It's "Guardians: Triplex"
 

·
Registered
Joined
·
986 Posts
My guess is that it is in the css style sheet (of course I don't know for sure, but that is my best guess.) I'm not sure which program converted your file (or if someone did it for you), but if you can open a copy as a .html extension (that is, you can open your book and save it with .html at the end - sorry you may know that), open it in your notepad so you can see the formatting. You can look at the very beginning, it will say a bunch of stuff like:

<style type="text/css">
After the style type line, look for anything that says COLOR or FONT COLOR (it will come before a tag, so within the first fifteen lines or so) and that is where your problem probably is. You can just erase the entire line that has COLOR or FONT COLOR in it, and that way you won't be forcing the color so people's ereaders can be set to martian purple or something else weird and it won't matter, the font will change so they can read it. If you don't see either of these things before you reach the tag, you can search your document (still in notepad) for , Text=, Link=, Alink=, VLink= to find the little piece that was forced and erase the formatting. It was probably a link color that was forced, so it might be pretty small, I'm thinking it's in the style sheet though (that stuff at the beginning).

I know that whole paragraph probably looks really confusing if you haven't done it before, but I really hope that helps a little bit.
 

·
Registered
Joined
·
1,167 Posts
Discussion Starter · #6 ·
This is how I was told to format (not sure if this answears your question)

Open your document in Word Choose "Save as HTML Filtered" Create a new folder and save your document there (this is a really important step!) Close down Word Find that folder. Don't open it! Just right click on the folder and chose "Send to" and pick "Zip file" This will create a zip file. Upload the zip file to Amazon.

DK, thank you so much, I will try that
 

·
Registered
Joined
·
5,162 Posts
Fixing the HTML is the surefire way to solve this.  That being said, you might have some luck selecting the entire document and remove any background colors / setting the font color to automatic.  A lot of these errors occur because at some point a document gets formatted to white background and black text.

Within the HTML, the best things to do is do a find and replace to remove any and all instances of "color=XXXX" and "Background=XXXXX"...that being said, if you don't know your way around HTML this can be a bit tricky.
 

·
Registered
Joined
·
1,167 Posts
Discussion Starter · #8 ·
I don't know my way around html :-(
But I will try
 

·
Registered
Persephone's Tears: A Romance in the Seventh Dimension
Joined
·
825 Posts
I had the same issue in my last book, and I format in Word 2007 (XP, I guess?).  This is going to sound weird but I fixed it by making certain the style defaulted to "Normal" for the primary text, even though it didn't follow the "Normal" formatting.  Scroll down through your document--does it default to "Normal" when your cursor is in the main body of your text?  If not, that may be your problem.  Don't know if that makes sense . . .
 

·
Registered
Joined
·
246 Posts
I used Word 2003 and saved as .doc.
Word 2007 and 2010, save as Word 97-2003. There is code that can foul up an upload.
Anything fancy can run into trouble.
I just did text and pictures and it was okay.
 

·
Registered
Persephone's Tears: A Romance in the Seventh Dimension
Joined
·
825 Posts
Strayer said:
I used Word 2003 and saved as .doc.
Word 2007 and 2010, save as Word 97-2003. There is code that can foul up an upload.
Anything fancy can run into trouble.
I just did text and pictures and it was okay.
Wow, great tip, thanks!
 

·
Premium Member
Joined
·
63,460 Posts
OK, I've removed a post that didn't contribute to either the conversation or to the tone we try to achieve here.  A question or comment about checking the HTML code could have been made without ranting. 

I will respond that the type of HTML error that was reported would only show up if one checked every page of a book with background set to black in a Kindle app or on a Kindle Fire.  Something I suspect very few of our authors do.  Maybe I am wrong?

Thanks to everyone for their helpful responses to trublue.  Trublue, let us know what you've been able to find.

Betsy
 

·
Registered
Joined
·
275 Posts
Betsy the Quilter said:
OK, I've removed a post that didn't contribute to either the conversation or to the tone we try to achieve here. A question or comment about checking the HTML code could have been made without ranting.

I will respond that the type of HTML error that was reported would only show up if one checked every page of a book with background set to black in a Kindle app or on a Kindle Fire. Something I suspect very few of our authors do. Maybe I am wrong?

Thanks to everyone for their helpful responses to trublue. Trublue, let us know what you've been able to find.

Betsy
OK - I'll try again without the ranting.

You don't check code by looking at every page by hand - you may miss something, and it takes too long.

Instead you look at the code - using the search function to ensure that there are no statements about fonts or colours within the HTML itself. You can control these - and you do so using CSS in an external style sheet or in the top of the file. There shouldn't be random changes within the HTML itself, clearly there is in this case.

The problem with Word (and all wordprocessors) is that they create very, very messy code. Which results in this type of error. It amazes me, I hope that's not too strong, that people will just "hope" that the Word HTML is "good enough". It may be, or it may not. It depends on how much editing you've done in it, and your editor, and anyone else who has used the file. At the very least you should submit a doc file that has been thru the Smashwords "nuclear" option - that will remove most of the random junk.

Checking the code removes the doubt, in the same way as hiring an editor removes doubt about the typos.
 

·
Registered
Joined
·
2,646 Posts
Thread raised my curiosity.

How do you not specify a font color?? Everything from Word to Scrivener to Pages has a color attribute as part of the text.

The only way I'm aware of is to generate the underlying HTML, opening the CSS and removing the color tags from the styles. Problem is, if your not working with the HTML directly then you're relying on the application, like Word and Scrivener.
 

·
Super Moderator
Joined
·
67,392 Posts
FWIW, I just got the sample and opened it on my HD7 and it looks fine.  I switched between black, white, and sepia background and the text changed color correctly. The only formatting issue I noticed is the paragraphs are not indented but separated with a blank line.  That's really more a style choice, though. 

That said, the location they specify is NOT in the sample.

I think I know what they mean, though, because I got a book one time that, when you used the black background, parts of it showed up as highlighted. . .it was very odd -- and the whole purpose of using the black background was negated.  That experience was with one of Krista Ball's books, so maybe she can help you fix yours.

 
1 - 16 of 16 Posts
Top