Kindle Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
See here:

As you see, it's the 2011 Kindle (with KSO) updated to the latest software. But it's doing this since 4.0.1. Of course, I also updated Calibre in the meantime.

At first it didn't look like this. Is it Calibre or the Kindle? Did you run into similar issues?
 

·
Administrator
Joined
·
63,461 Posts
Is it doing that to all books?  Have you tried looking at a book downloaded directly from Amazon?  (There are lots of free books if you want to do some testing and don't have any purchased from Amazon.)

Betsy
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
It does it only to selected texts downloaded from the web, converted with Calibre then uploaded to the Kindle. Books are working just fine.

But the point is it didn't do this before the 4.0.1 update or the appropriate Calibre update.
 

·
Administrator
Joined
·
63,461 Posts
My gut says it's probably Calibre; I would suggest you look at the settings and see if there isn't somewhere it's adding some padding by default.  I haven't used Calibre in years, but since I haven't seen this complaint before and we've had a lot of people with updated K4s, including me, I suspect Calibre first.

Betsy
 

·
Registered
Joined
·
5,087 Posts
avid said:
It does it only to selected texts downloaded from the web, converted with Calibre then uploaded to the Kindle. Books are working just fine.
What is the source of the downloaded text? What conversion options are you using in Calibre?

It's really mystifying, I've never seen anything like that before. If it is only happening with some text downloaded from the web and not with any books, I would suspect the source of having some weirdness about it. Could you get a picture of it from a different angle? And a screen shot?

Mike
 

·
Registered
Joined
·
12,250 Posts
That is odd. Have you tried to re-convert in calibre . Under convert try going to output mobi and change the kindle option to "old" mobi. Not new, not both. I have to do that with some books that have a fixed font setting and other weird formatting that appear when there is a bad KF8 file (new mobi).

No clue if that would work though in your case. I guess that depends on the source file.
 

·
Administrator
Joined
·
63,461 Posts
Searches show there was a known bug in some early versions of Calibre, years ago, that resulted in wide left margins, but I haven't been able to find anything recent.

You might go to the Calibre forum on www.Mobileread.com

Betsy
 

·
Super Moderator
Joined
·
67,251 Posts
I have never seen anything like that. . .except when a bright light was shining on the kindle and reflecting glare.

If it's not every book, it's not the Kindle. . . .though I also can't imagine why any sort of converter would be causing that sort of problem.

Really strange.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
Thanks for your help. I just let everything default in Calibre. It says "old" Mobi. I go to their support forum.
 

·
Registered
Joined
·
5,087 Posts
OK, I completely misunderstood what the question was, which was no doubt about the wide left margin. Doh. I looked at it and only saw the blank spot in the middle of the screen (caused by reflected light, no doubt). I have seen uneven margins in books before, and it's neither the Kindle nor Calibre that is responsible.

Margins can be offset by source material, the Kindle doesn't really control that. It just shows what the HTML code says to do. I think what you need to do it go into Calibre's Convert Book feature and go to MOBI Output and check the box labeled Ignore Margins. That way Calibre will set the margins itself instead of following the margins specified in the text file you got, and change it to the ones specified in the Page Setup part of Convert Books.

I leave the Ignore Margins box checked in my default settings.

Mike
 

·
Super Moderator
Joined
·
67,251 Posts
jmiked said:
OK, I completely misunderstood what the question was, which was no doubt about the wide left margin. Doh. I looked at it and only saw the blank spot in the middle of the screen (caused by reflected light, no doubt). I have seen uneven margins in books before, and it's neither the Kindle nor Calibre that is responsible.

Margins can be offset by source material, the Kindle doesn't really control that. It just shows what the HTML code says to do. I think what you need to do it go into Calibre's Convert Book feature and go to MOBI Output and check the box labeled Ignore Margins. That way Calibre will set the margins itself instead of following the margins specified in the text file you got, and change it to the ones specified in the Page Setup part of Convert Books.

I leave the Ignore Margins box checked in my default settings.

Mike
Me too. I didn't even notice the margin. ::)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
jmiked said:
Margins can be offset by source material, the Kindle doesn't really control that. It just shows what the HTML code says to do. I think what you need to do it go into Calibre's Convert Book feature and go to MOBI Output and check the box labeled Ignore Margins. That way Calibre will set the margins itself instead of following the margins specified in the text file you got, and change it to the ones specified in the Page Setup part of Convert Books.
Thanks Mike, the next time I download an article from here -http://www.stratfor.com/geopolitical-weekly- I'll do this.
 
1 - 12 of 12 Posts
Top