Kindle Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
769 Posts
Discussion Starter · #1 ·
The Kindle for Mac application available on amazon is for Macs using OS 10.5 and above.  Is there a Kindle for Mac that works on older operating systems?  If not is anyone aware of any plans to create one?  I'd like to get the Kindle for Mac application for my laptop but it runs on OS 10.4.11.
 

·
Registered
Joined
·
769 Posts
Discussion Starter · #3 ·
I suppose I could update the OS but I'd have to buy a new OS and I think it is also the wrong kind of Mac CPU too.  I have a titanium G4 powerbook.
 

·
Registered
Joined
·
3,290 Posts
I don't think your machine will handle an upgrade to Lion either.  I could be wrong though.
 

·
Registered
Joined
·
685 Posts
Hmmm, this must be a recent development because I have it on my laptop, which is still on tiger. I downloaded it within the last couple of months even. I will check the version when I get back there today.
 

·
Registered
Joined
·
5,087 Posts
TraceyC/FL said:
Hmmm, this must be a recent development because I have it on my laptop, which is still on tiger. I downloaded it within the last couple of months even. I will check the version when I get back there today.
Is your laptop a PPC or Intel?

Mike
 

·
Registered
Joined
·
1,438 Posts
StephenLivingston said:
I'm not sure. How can one tell? It's a G4 Powerbook 15" titanium model Mac.

It's a PowePC processor:

https://secure.wikimedia.org/wikipedia/en/wiki/PowerBook_G4

Rosetta helps Intel processors use PPC apps, but I don't think it'd help PPC processors use Intel apps.
I think it's time to consider upgrading if you can. And with Apple recently releasing OS 10.7 it looks like Intel Core Duo processors are being left behind, only Core 2 Duo and higher are being supported. Thankfully, prices have come down a bit:

http://store.apple.com/us

Best of luck!

--- edited... no self-promotion outside the Book Bazaar forum. please read our Forum Decorum thread.
 

·
Registered
Joined
·
5,087 Posts
Yeah, Rosetta won't help a PPC (G4) machine run Intel apps. I have an early Mac mini (G4) that I use for a server, and it's still on 10.4.11. It won’t run the Kindle app, either.

Mike
 
1 - 14 of 14 Posts
Top