Kindle Forum banner
21 - 22 of 22 Posts

· Registered
Joined
·
1,235 Posts
I totally had this problem with my K2.  CS sent me a new cord and it worked for awhile but is not recognizing it now.  I work on a laptop so the suggestion about using a back port didn't help.  The problem went on the back burner because I got a K3 and so far haven't had any problems.  My husband is using the K2 now, so I need to get this figured out.  I was interested to read the post about using the Blackberry cord.  I may have to look for one of those.
 

· Registered
Joined
·
1,040 Posts
If you are plugged into ANY USB port on your computer, it should recognize the device so you can move files. However, to charge, (and if your battery is low,) you need to be plugged into a POWERED USB port. Usually these are the ones on the back of the computer. Newer computers may have two banks of USB ports on the back of the case, one bank of which may or may not be powered. You can also plug into a USB hub that is powered. (If there is no power adapter plugged into the wall or power strip, it is NOT a powered hub, even if it has lights on it.)

If you are plugged into a powered hub, and your computer still can't see (or charge) your device, you might have a defective cord. Test it in the wall plug to see if it charges. If it charges when plugged into the wall, restart everything (including your computer,) and try again in a powered USB port. If that still fails, then you need to take it on up line to tech support. Especially since it worked for awhile but is failing again without you making any changes in your equipment or procedures.

One last: I've used the "Safely remove..." icon to eject without issues. My OS is Win7 Ultimate ed.
 
21 - 22 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top