Kindle Forum banner

1 - 20 of 76 Posts

·
Registered
Joined
·
1,916 Posts
Discussion Starter #1
I've been trying to update my Reading Page for the last few days, but keep getting this error message:

ASIN not found in Amazon database: This item is not accessible through the Product Advertising API.
This message comes up no matter what book I search on, including some that are already on my list. It even came up when I just tried to move a book down a notch.

Has anyone else had this problem and/or anyone know of a fix? Aside from just liking to show off post what I've been reading, I've actually been using this feature as my own record of recent reading. I also am frequently enabled by get reading suggestions from seeing other people's lists.
 

·
Super Moderator
Joined
·
67,245 Posts
Huh. I just updated my reading page and it seems to be working as expected. Are you use ing 'find ASIN' to get the ASIN to input into the tool. As long as you spell things correctly that will give you the correct number. And it does take a bit of time for it to process the changes once you hit 'save'. The thing I sometimes forget I have to do is to refresh the Kboards page after I've updated the reading page so that it refreshes my signature. I actually think it changes right away for the rest of you; it's just that I see the old one until I refresh or after I've closed the browser and come back.

I'll alert Betsy to this . . . she may have some further insights. It might help to know what sort of system you're using? Desktop/laptop/tablet etc. . . . .
 

·
Registered
Joined
·
1,916 Posts
Discussion Starter #3
Thanks for checking on this. I thought it might not be a universal problem because I couldn't find any other comments about it. It's happening for me on both an iPad using iOS 10 and a Windows 7 laptop. I've tried using the  'Find ASIN' (which is the usual way I update), but I've also tried going to the Amazon page directly and copying the ASIN from there. I do wait for the changes to save; that's the point where I get the error message.

Since you're not having the problem, I wonder if my page has become corrupted in some way. I'll wait a few days to see if any other ideas pop up here. If not, maybe I'll have to try deleting my page and starting fresh.


 

·
Super Moderator
Joined
·
67,245 Posts
gdae, are you still having issues?
 

·
Registered
Joined
·
1,916 Posts
Discussion Starter #5
I just tried this again on my iPad and still get the same error message. I don't turn on my laptop as often these days, but will probably use it tomorrow and will try again on there. If it's still not working, I'll try deleting my Reading Page and setting it up again.

By the way, although I'm frustrated this isn't working, I'm amused that the last book I was able to post, which has actually now disappeared, was The Invisible Library.
 

·
Registered
Joined
·
1,916 Posts
Discussion Starter #6
Fixed! It still wasn't working on my laptop, so I deleted all the book entries, and also my forum signature. I saved the changes and ended up with a blank Reading Page. I set up the page again, and now it works normally on both the laptop and iPad. I guess this served as a reboot. I still have no idea what caused the problem, but glad to have the Reading Page working again.
 

·
Super Moderator
Joined
·
67,245 Posts
Weird . . . but I'm glad you got it sorted . . . sorry it was so much work.

And sorry I couldn't be more help: I'm not adept at coding at all and Betsy's been on vacation. ::)

I suspect that, somehow, a digit got dropped and it just wasn't apparent. So, yeah, deleting and re-doing fixed the problem.
 

·
Moderator
Joined
·
5,880 Posts
I'm also having problems updating my Reading Page - though in my case I don't get an error message, just books appearing and disappearing each time I save it.

It's a problem I've noticed before but today it seems much worse than usual. I've just updated my page and saved it - and two books were missing. So I saved it again and they reappeared and three others were missing. After about a half dozen saves I've had results ranging anywhere from one to seven books missing, not always the same ones, including at one point my 'currently reading' selection, which is now back. Not once have I managed to get a complete save with no missing books.

Since the missing books change each time, I'm assuming I've got the correct ASINs - so what else could be the problem? Is it really a case of removing everything and starting again, or does that only work when you've been getting an actual error message?

Suggestions welcome.

(for clarity, I'm using amazon.co.uk)
 

·
Administrator
Joined
·
63,461 Posts
Linjeakel said:
I'm also having problems updating my Reading Page - though in my case I don't get an error message, just books appearing and disappearing each time I save it.

It's a problem I've noticed before but today it seems much worse than usual. I've just updated my page and saved it - and two books were missing. So I saved it again and they reappeared and three others were missing. After about a half dozen saves I've had results ranging anywhere from one to seven books missing, not always the same ones, including at one point my 'currently reading' selection, which is now back. Not once have I managed to get a complete save with no missing books.

Since the missing books change each time, I'm assuming I've got the correct ASINs - so what else could be the problem? Is it really a case of removing everything and starting again, or does that only work when you've been getting an actual error message?

Suggestions welcome.

(for clarity, I'm using amazon.co.uk)
Usually this, with Amazon.com, has been an issue with Amazon's servers, and usually goes away in a day or so. If it's still doing it tomorrow, let us know, Linda.

Betsy
 

·
Registered
Joined
·
1,916 Posts
Discussion Starter #11
It does sound different from the problem that I had, so hopefully it's just a temporary problem with Amazon's server as Betsy said.  If it does turn out that you need to redo the whole page, I can say that it didn't actually take that long to do that. ( I did choose to leave out some of the books I've read that weren't my favorites.) I took a screenshot of the page before I started so that I'd have a record of everything that was there.
 

·
Super Moderator
Joined
·
67,245 Posts
Linda, I've had happen what you did . . . but it's been a while. As Betsy said it might have had to do with Amazon servers but, more specifically, I think it had to do with how the board software communicated with their servers. Best as I can recall, I haven't had it happen since the Big Changeover happened and that's been a while. So I may just be drawing a connection out of a coincidence.
 

·
Moderator
Joined
·
5,880 Posts
I've been monioring this over the last couple of days and just now is the first time I've been able to save without any missing books - I did it twice to make sure it wasn't a fluke/coincidence, but all is OK at the moment.

I have no way of knowing if it was solely an Amazon server problem or a communication problem between this board's software and the Amazon servers. Either way, it appears fixed for the present and, let's face it, not the most pressing problem in the world. It's probably something that we'll see again from time to time.



 

·
Moderator
Joined
·
5,880 Posts
This problem has continued to happen intermittently over the last few months, though an extra press or two of the save button usually fixes it. Today though, I'm back to where I was before with anything up to ten books missing each time I save - and not always the same ones each time.

Has there been any progress on pinning down the problem, or is this just something we have to live with?

 

·
Super Moderator
Joined
·
67,245 Posts
:(

I just updated my page this morning and had no problem . . . I wonder if it's to do with pulling from the UK site?  :(
 

·
Moderator
Joined
·
5,880 Posts
Ann in Arlington said:
:(

I just updated my page this morning and had no problem . . . I wonder if it's to do with pulling from the UK site? :(
Interestingly, over the last couple of weeks or so, my internet security software keeps telling me it can't verify the authenticity of the site each time I go on to Amazon, like the certificate is expired or something. I have no idea whether the problem is with Amazon, my browser or my security software - I use Kapersky. The problem only occurs on Amazon and I have no idea if it's related to the Reading Page problem.

To be honest, I'm not sure if I've got the patience at the moment to be bothered to look into it more closely. The internets is very frustrating at times..... :-\
 

·
Moderator
Joined
·
5,880 Posts
Just to say that this problem hasn't gone away. I only update periodically now instead of every time I start a new book, because of the frustration of having to save the changes about ten times before I can get most of the blanks to go away.

I tend to just do it till the panel which shows in the footer of posts is populated and ignore the fact that half a dozen are still missing from the rest of the list.

Are we still assuming this is a problem with Amazon UK servers and not a problem we can solve from this end?
 

·
Administrator
Joined
·
63,461 Posts
Hmmm....  Not sure, Linda.  I wonder if any other UK members are having the same problem?  I wonder if I can link to books in the UK store and test it?

Are you able to link to books in the US store?  If so, do they act the same?
 

·
Moderator
Joined
·
5,880 Posts
Betsy the Quilter said:
Hmmm.... Not sure, Linda. I wonder if any other UK members are having the same problem? I wonder if I can link to books in the UK store and test it?

Are you able to link to books in the US store? If so, do they act the same?
If I change to the US store and press save, I get red error messages for about half the books saying something like "this ASIN not found in the Amazon database" but when I search for those books on amazon.com using the same ASINs, the books are there. So far as I can tell it's the same books every time.

Normally when using the UK database option I don't get an error message, just a blank on the list (actually it just says the word "by") and a blank where the cover should be on the strip that appears in the post footer, and on the 'reading page' the gaps just close up so you can't actually tell any are missing. There's no error message and the missing books are different every time.
 

·
Administrator
Joined
·
63,461 Posts
Hmmm....

If you refresh your screen instead of hitting save again, do the books appear?

Also, I'd be curious if, instead of hitting save again until you see them, if you would post here in this thread, so we can see if the books are in your sig for us and just not showing for you.

Betsy.

 
1 - 20 of 76 Posts
Top